Stats from wrong project?

This forum provides an FAQ for users as well as allowing you to ask questions about MundayWeb's very popular BOINC stats services.
Post Reply
ChertseyAl
Established Member
Posts: 104
Joined: Tue Aug 26, 2008 8:13 pm

Stats from wrong project?

Post by ChertseyAl » Sat Dec 08, 2012 7:45 pm

Just noticed that I have apparently 12945.00 credits for Volpex. I haven't, I've actually got only 9.

However, I do have 12945.00 for 3x+1 (which is correct) - Suspicious! Are you picking up Volpex stats from the 3x+1 project?

Oh, and for [email protected] you have me as having 439 credits - I actually have 10335.

These might have been wrong for some time, I only noticed now because I was trying to see if you had any projects missing that you could add.

Image as of now:

Image

Cheers,

Al.

Neil
Site Admin
Posts: 1325
Joined: Mon Apr 18, 2005 8:35 pm
Location: UK
Contact:

Re: Stats from wrong project?

Post by Neil » Sun Dec 09, 2012 4:21 pm

Hi Al,

For [email protected], in the stats file from the project here is you entry:

Code: Select all

<user>
 <id>626</id>
 <name>ChertseyAl</name>
 <country></country>
 <create_time>1241136000</create_time>
 <total_credit>439.000000</total_credit>
 <expavg_credit>0.000000</expavg_credit>
 <expavg_time>0.000000</expavg_time>
 <cpid>d41d8cd98f00b204e9800998ecf8427e</cpid>
</user>
Also, on their site you show as having 439 credits: http://boinc.drugdiscoveryathome.com/sh ... userid=626. I think their stats system is messed up! I would suggest contacting the authors of the project.

For Volpex the account ID for this project was set to 272 when infact your account ID for this project is 604. Not sure how this happened. Anyway, I've updated your account to use the correct ID.

I've double checked my URLs and the database and I can see no error in the config.

Hope this helps,

Neil.

ChertseyAl
Established Member
Posts: 104
Joined: Tue Aug 26, 2008 8:13 pm

Re: Stats from wrong project?

Post by ChertseyAl » Sun Dec 09, 2012 7:28 pm

Hi Neil,

FWIW the problem with [email protected] is that my CPID is wrong. Posted in their forums.

Funny that Free-DC is showing the correct number though. Perhaps they've stopped collecting stats. I'll ask over there.

Cheers,

Al.

ChertseyAl
Established Member
Posts: 104
Joined: Tue Aug 26, 2008 8:13 pm

Re: Stats from wrong project?

Post by ChertseyAl » Tue Feb 05, 2013 11:20 am

Hi Neil,

FWIW, I figured this one out, but it does potentially highlight a bug ;)

Looking the the latest [email protected] user dump, there are 2 ChertseyAls - The low ID one (626) and the high ID one (3361) which is the correct one. ISTR long ago that the project lost it's DB and we had to sign up again. Looks like the ghost of my previous incarnation still exists.

Anyway, I guess when I added the project here I used my user name rather than ID and it found the first (old) one. I *think* user names don't have to be unique, so maybe you should be checking for multiple entries when adding a project by name?

So, I deleted the project here and added it again via my ID and now I get the correct stats. Which is nice :)

I'll post something over at [email protected] also.

Edit: Jord has confirmed over at DD that the only unique identifier is your email address, so searching on name might be problematic :(

Cheers,

Al.

Neil
Site Admin
Posts: 1325
Joined: Mon Apr 18, 2005 8:35 pm
Location: UK
Contact:

Re: Stats from wrong project?

Post by Neil » Thu Feb 07, 2013 11:45 pm

Hi Al,

With the new site and the original one, multiple hits for the same account name are all displayed by both sites when searching for a project to add. It's up to the user to decide which one to add from the search results.

Perhaps when you searched there was only one ChertseyAl account for [email protected]?

Cheers,

Neil.

ChertseyAl
Established Member
Posts: 104
Joined: Tue Aug 26, 2008 8:13 pm

Re: Stats from wrong project?

Post by ChertseyAl » Fri Feb 08, 2013 8:06 pm

Hi Neil,

I deleted DD, and added it again. Sure enough both of me appeared, so, yeah, that does actually work. Sorry about the red herring :(

I think when I initially added it there was just the one of me. Once I'd had to sign up again I obviously never noticed that my stats weren't updating here.

I seem to have a spook ID in another project, but it's not a problem here as I obviously got it right when I added that one :)

Cheers,

Al.

Post Reply